class HashList < Object
TODO: Perhaps this should have a different name, since insert/delete operations may be slow? (if they were to be implemented)
TODO: This could be implemented using two arrays.
TODO: Document this class.
reverse_each_pair is an alias for reverse_each_index.
length is an alias for size.